• Avatar do Utilizador
  • Avatar do Utilizador
  • Avatar do Utilizador
  • Avatar do Utilizador
#184400
Então antes de começar venho dizer que comprei este Eachine Wizard X220, pois era um drone de suposto "iniciante" e junto com ele comprei também uns óculos Eachine (não me lembro do modelo) e acessórios. Até aí tudo bem, mas os problemas começam quando eu monto o drone pela primeira vez, e sem saber ponho as hélices de trás trocadas, o que fazia com que a traseira não levantasse voo.
Pensava que era um problema do drone, então vim aqui ao forum e pedi ajuda. Lá vocês esclareceram-me que podiam estar trocadas e eu voltei a fazer e deu certo. Acontece que eu queria o melhor para o meu drone, então fui ver uns vídeos de como fazer uma configuração básica no YouTube.

O PROBLEMA:

Ao mexer onde não devia, estraguei o Failsafe pré-feito pela Eachine e tentei resolver resetando o drone no botão do betaflight que diz Reset (acho eu que é assim).
Ao fazer isso o comando não respondia então eu voltei a fazer o bind com a peça que vem para ligar ao recetor. E...nada. Não acontece nada.
Preciso da vossa ajuda para, se possivel, me explicarem o que preciso de fazer para por o comando a comunicar com o drone outra vez, e posteriormente fazer um Failsafe decente e seguro.
IMPORTANTE (ou não): O drone está completamente resetado via Betaflight e também resetei o comando na opção de Factory Reset deste. Mesmo depois de ter feito o Bind os motores não reagem nem aparece nada no Betaflight.

Vai fazer quase um ano, eu desisti durante meses pois não pareceu haver solução mas agora estou determinado não desistir!
Agradeço o vosso tempo gasto a ler isto e, se possível, respondam por favor até domingo à noite para ver se resolvo isto já este fim de semana.
Obrigado mais uma vez e Boa Noite.
#184402
O tipo de receptor não está correctamente configurado no Betaflight.

É flysky certo? Deve ser ibus ou sbus, na tab configurações tens lá isso, vê se a porta uart certa está para serial RX.
#184403
GhostMaster Escreveu:
10 nov 2019, 03:07
O tipo de receptor não está correctamente configurado no Betaflight.

É flysky certo? Deve ser ibus ou sbus, na tab configurações tens lá isso, vê se a porta uart certa está para serial RX.
na parte da configuração, na 1a pus SBUS e na segunda que apareceu pus IBUS. Mas na porta tenho UART 1 2 e 3 e tenho serial rx para cada uma delas, ainda com outras informaçoes. qual escolho?
#184405
ElChampion13 Escreveu:
GhostMaster Escreveu:
10 nov 2019, 03:07
O tipo de receptor não está correctamente configurado no Betaflight.

É flysky certo? Deve ser ibus ou sbus, na tab configurações tens lá isso, vê se a porta uart certa está para serial RX.
na parte da configuração, na 1a pus SBUS e na segunda que apareceu pus IBUS. Mas na porta tenho UART 1 2 e 3 e tenho serial rx para cada uma delas, ainda com outras informaçoes. qual escolho?
Não deves assinalar todas as portas como serial rx, salvo erro só o uart 1 é que terá essa função.
Na página de configuração escolhes iBus na zona do receptor e depois na página das portas é que assinalas o Uart1 como serial rx e nada mais que isso.

Se não funcionar como iBus tenta com o outro protocolo que o Ghost disse :)
#184408
se fores perto de Mafra posso tentar dar uma vista de olhos pessoalmente, ou então na zona de LX em princípio também se arranja uma "alma caridosa" para dar uma ajuda eheheh
De certeza que se mete isso a voar rapidamente
#184414
Se for uma f4 só uma das Uart dá pra ibus, acho que não pode ter inversor, e sbus tem de ter inversor.
Build 5" 6S

@GhostMaster , amanhã vou testar se o tem[…]

Se for uma f4 só uma das Uart dá pra[…]

Boas escolhas, bons voos, vai dando novidades.

Contrução de um drones

Isso poderia ser uma excelente ideia, como poder[…]

Ajudem o fórum usando este link para compras na Banggood